Bump Node to 24.22.1 to block the compromised eMudhra intermediates by robertjchen · Pull Request #116 · Expensify/GitHub-Actions · GitHub
Skip to content

Bump Node to 24.22.1 to block the compromised eMudhra intermediates - #116

Merged
justinpersaud merged 2 commits into
mainfrom
robert-nodeEmudhraBlocklist
Oct 21, 2026
Merged

justinpersaud merged 2 commits into
mainfrom
robert-nodeEmudhraBlocklist

Conversation

@robertjchen

Copy link
Copy Markdown
Contributor

Details

Bumps Node to 24.22.1, which rejects TLS chains through the eight compromised eMudhra intermediate CAs (nodejs/node#66871). Node uses its own compiled-in root store, so OS ca-certificates updates don't cover it.

Related Issues

For https://github.com/Expensify/Expensify/issues/693812

Manual Tests

  1. Run nvm install and confirm node -v prints v24.22.1.
  2. Run node -e 'fetch("https://dv-g3b-emudhra.we-have-a-problem.com/").then(r=>console.log(r.status)).catch(e=>console.log(e.cause?.code))'.
  3. Confirm it prints CERT_REVOKED.

Linked PRs

N/A

@chatgpt-codex-connector

chatgpt-codex-connector Bot commented Oct 21, 2026 •

Copy link
Copy Markdown

@github-actions

github-actions Bot commented Oct 21, 2026 •

Copy link
Copy Markdown

All contributors have signed the CLA ✍️ ✅
Posted by the CLA Assistant Lite bot.

@chatgpt-codex-connector chatgpt-codex-connector Bot left a comment

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

💡 Codex Review

Here are some automated review suggestions for this pull request.

Reviewed commit: b2db92a9f9

ℹ️ About Codex in GitHub

Codex has been enabled to automatically review pull requests in this repo. Reviews are triggered when you

  • Open a pull request for review
  • Mark a draft as ready
  • Comment "@codex review".

If Codex has suggestions, it will comment; otherwise it will react with 👍.

When you sign up for Codex through ChatGPT, Codex can also answer questions or update the PR, like "@codex address that feedback".

Comment thread package.json
"type": "module",
"engines": {
"node": "24.19.0",
"node": "24.22.1",

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

P1 Badge Match the npm engine bundled with Node 24.22.1

Node 24.22.1 bundles npm 11.19.1, but package.json still requires exactly npm 11.17.0 while .npmrc enables engine-strict. Consequently, setup-node workflows such as .github/workflows/test.yml and .github/workflows/verifyPeerReview.yml reach npm ci with npm 11.19.1 and exit with EBADENGINE before tests or peer-review checks run. The tagged Node source identifies the bundled npm version as 11.19.1, and npm documents that engines.npm constrains compatible npm versions and engine-strict makes mismatches fatal. Update the npm engine and lockfile entry to 11.19.1, or use a compatible range.

Useful? React with 👍 / 👎.

Copy link
Copy Markdown
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Fixed in 91811f2, bumped npm to 11.19.1 in package.json and package-lock.json.

@robertjchen

Copy link
Copy Markdown
Contributor Author

exfy-clabot Bot added a commit to Expensify/CLA that referenced this pull request Oct 21, 2026
@justinpersaud
justinpersaud merged commit b8394b9 into main Oct 21, 2026
10 of 13 checks passed
@justinpersaud
justinpersaud deleted the robert-nodeEmudhraBlocklist branch October 21, 2026 17:54
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants