Features | Getting started | Contributing | License
Aries Framework JavaScript is a framework written in TypeScript for building SSI Agents and DIDComm services that aims to be compliant and interoperable with the standards defined in the Aries RFCs.
Some features are not yet supported, but are on our roadmap. Check the roadmap for more information.
- ✅ React Native
- ✅ Node.JS
- ✅ Report Problem Protocol (RFC 0035)
- ✅ Issue Credential Protocol (RFC 0036)
- ✅ Issue Credential Protocol V2 (RFC 0453)
- ✅ Present Proof Protocol (RFC 0037)
- ✅ Basic Message Protocol (RFC 0095)
- ✅ Connection Protocol (RFC 0160)
- ✅ Out of Band Protocol (RFC 0434)
- ✅ DID Exchange Protocol (RFC 0023)
- ✅ Mediator Coordination Protocol (RFC 0211)
- ✅ Indy Credentials (with
did:sovsupport) - ✅ HTTP & WebSocket Transport
- ✅ Connection-less Issuance and Verification
- ✅ Smart Auto Acceptance of Connections, Credentials and Proofs
- 🚧 Receiving and Verifying revocable Indy Credentials
- 🚧 W3C Linked Data VCs, BBS+ Signatures
- ✅ Multi Tenancy
- ❌ Browser
| Package | Version |
|---|---|
| @aries-framework/core |
|
| @aries-framework/node |
|
| @aries-framework/react-native |
|
| @aries-framework/action-menu |
|
| @aries-framework/question-answer |
|
| @aries-framework/tenants |
|
Documentation on how to get started with Aries Framework JavaScript can be found at https://aries.js.org
To get to know the AFJ flow, we built a demo to walk through it yourself together with agents Alice and Faber.
Although Aries Framework JavaScript tries to follow the standards as described in the Aries RFCs as much as possible, some features in AFJ slightly diverge from the written spec. Below is an overview of the features that diverge from the spec, their impact and the reasons for diverging.
If you would like to contribute to the framework, please read the Framework Developers README and the CONTRIBUTING guidelines. These documents will provide more information to get you started!
The Aries Framework JavaScript call takes place every week at Thursday, 14:00 UTC via Zoom. This meeting is for contributors to groom and plan the backlog, and discuss issues. Meeting agendas and recordings can be found here. Feel free to join!
Hyperledger Aries Framework JavaScript is licensed under the Apache License Version 2.0 (Apache-2.0).

