{{ message }}
Repository navigation
[CI] Remove the phpunit 13.4 conflict, require Codeception 5.3.7 - #4161
Merged
Merged
Conversation
Codeception 5.3.7 supports PHPUnit 13.4 (Codeception/Codeception#6953, fixes #6952), so the temporary `conflict` "phpunit/phpunit": ">=13.4" is no longer needed. Raise the require-dev floor to ^5.3.7 so this repository's own CI never pairs PHPUnit 13.4 with an older Codeception. Co-Authored-By: Claude <noreply@anthropic.com>
Contributor
There was a problem hiding this comment.
Copilot review overview
🟢 Approved
The dependency constraints align with the verified Codeception 5.3.7 compatibility release.
Review effort: Balanced
Findings: None
What changed in this PR
Updates test dependencies after Codeception 5.3.7 restored PHPUnit 13.4 compatibility.
Changes:
- Requires Codeception 5.3.7 or later.
- Removes the temporary PHPUnit 13.4 conflict.
💡 Add a code-review agent skill or configure MCP servers for context-aware, tailored reviews. Learn more in the docs.
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to subscribe to this conversation on GitHub.
Already have an account?
Sign in.
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.




Changes in this pull request
Related: Codeception/Codeception#6952
Follow-up of #4158.
Codeception 5.3.7 fixes the PHPUnit 13.4 incompatibility (Codeception/Codeception#6953). It passes the
EmittertoCli\BuilderandRegistry::init()on PHPUnit ≥ 13.4, and keeps the old calls below that. So the temporary pin can go."phpunit/phpunit": ">=13.4"fromconflict.require-devcodeception/codeceptionfrom^5.3.5to^5.3.7. This repository's own CI then can't combine PHPUnit 13.4 with a Codeception that lacks the fix, including the lowest legs.Dependents: the conflict is gone, so bundles and projects are unrestricted again. Their highest legs resolve Codeception 5.3.7, and their lowest legs stay on PHPUnit 12.5. No release ever shipped the conflict, so there is no released constraint to clean up.
Additional info
composer validatepasses.--prefer-lowest: codeception 5.3.7 + phpunit 12.5.23.2025.4→2026.3→2026.x. Both carry the same conflict.2026.3and ee-pimcore12.3get the same change in separate PRs.🤖 Generated with Claude Code