{{ message }}
Repository navigation
Resolve semver ReDoS vulnerability - #264
Closed
FredrikMeyer with Copilot wants to merge 2 commits into
Closed
FredrikMeyer with Copilot wants to merge 2 commits into
FredrikMeyer with Copilot wants to merge 2 commits into
Conversation
Co-authored-by: FredrikMeyer <1738405+FredrikMeyer@users.noreply.github.com>
Copilot
AI
changed the title
[WIP] Fix semver vulnerable to Regular Expression Denial of Service
Resolve semver ReDoS vulnerability
Oct 12, 2026
FredrikMeyer
marked this pull request as ready for review
October 12, 2026 08:09
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.

The lockfile resolved vulnerable
semver7.3.7, affected by ReDoS whenRangereceives an untrusted version range.semveror passes untrusted ranges toRange. It is used transitively by Docusaurus/Babel tooling with project metadata, so the vulnerable path is not reachable from application inputs. This update primarily addresses scanner findings. Confidence: high.Original prompt
This section details the Dependabot vulnerability alert you should resolve
<alert_title>semver vulnerable to Regular Expression Denial of Service</alert_title>
<alert_description>Versions of the package semver before 7.5.2 on the 7.x branch, before 6.3.1 on the 6.x branch, and all other versions before 5.7.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the function new Range, when untrusted user data is provided as a range.</alert_description>
high
https://nvd.nist.gov/vuln/detail/CVE-2022-25883 https://github.com/npm/node-semver/pull/564 https://github.com/npm/node-semver/commit/717534ee353682f3bcf33e60a8af4292626d4441 https://security.snyk.io/vuln/SNYK-JS-SEMVER-3247795 https://github.com/npm/node-semver/blob/main/classes/range.js#L97-L104 https://github.com/npm/node-semver/blob/main/internal/re.js#L138 https://github.com/npm/node-semver/blob/main/internal/re.js#L160 https://github.com/npm/node-semver/pull/585 https://github.com/npm/node-semver/commit/928e56d21150da0413a3333a3148b20e741a920c https://github.com/npm/node-semver/pull/593 https://github.com/npm/node-semver/commit/2f8fd41487acf380194579ecb6f8b1bbfe116be0 https://github.com/npm/node-semver/blob/main/classes/range.js%23L97-L104 https://github.com/npm/node-semver/blob/main/internal/re.js%23L138 https://github.com/npm/node-semver/blob/main/internal/re.js%23L160 https://security.netapp.com/advisory/ntap-20241025-0004 https://github.com/advisories/GHSA-c2qf-rxjj-qqgwGHSA-c2qf-rxjj-qqgw, CVE-2022-25883
semver
npm
<vulnerable_versions>7.3.7</vulnerable_versions>
<patched_version>7.5.2</patched_version>
<manifest_path>yarn.lock</manifest_path>
<task_instructions>Resolve this alert by updating the affected package to a non-vulnerable version. Prefer the lowest non-vulnerable version (see the patched_version field above) over the latest to minimize breaking changes. Include a Reachability Assessment section in the PR description. Review the alert_description field to understand which APIs, features, or configurations are affected, then search the codebase for usage of those specific items. If the vulnerable code path is reachable, explain how (which files, APIs, or call sites use the affected functionality) and note that the codebase is actively exposed to this vulnerability. If the vulnerable code path is not reachable, explain why (e.g. the affected API is never called, the vulnerable configuration is not used) and note that the update is primarily to satisfy vulnerability scanners rather than to address an active risk. If the advisory is too vague to determine reachability (e.g. 'improper input validation' with no specific API named), state that reachability could not be determined and explain why. Include a confidence level in the reachability assessment (e.g. high confidence if the advisory names a specific API and you confirmed it is or is not called, low confidence if the usage is indirect and hard to trace). If no patched version is available, check the alert_description field for a Workarounds section — the advisory may describe configuration changes or usage patterns that mitigate the vulnerability without a version update. If a workaround is available, apply it and leave a code comment referencing the advisory identifier explaining it is a temporary mitigation. If neither a patch nor a workaround is available, explain in the PR description why the alert cannot be resolved automatically so a human reviewer can take over. Inspect the repository to determine which package manager is used (e.g. lock files, config files, build scripts) and use that tooling to perform the update — do not edit lock files directly. If the version constraint in the manifest (e.g. package.json, Gemfile, pyproject.toml) caps the version below the fix, update the constraint first. For transitive dependencies, determine whether it is simpler to update the direct dependency that pulls in the vulnerable package or to update the transitive dependency directly, and choose the least disruptive approach. If upgrading to fix the vulnerability forces a major version bump or known breaking changes, review the changelog or release notes, then audit the codebase for usage of affected APIs and fix any breaking changes that are found. If the package manager fails to resolve dependencies (e.g. peer dependency conflicts, incompatible engine constraints), document the error in the PR description rather than attempting increasingly complex workarounds. After updating, check the lock file to confirm the package no longer resolves to a version in the vulnerable range. Keep changes minimal and tightly scoped. Ensure tests, build, type checking, and linting all pass a...